Fix the GPG warning using Y-PPA manager

Here’s a quick tip,

If you ever encounter this error(check the screenshot), the easiest thing that you could do to fix it AFAIK is to install the Y-PPA manager and let it try to import all the missing GPG keys.

This error might pester you when you try updating or install new software.
This error might pester you when you try updating or install new software.

Here’s how you can install it :

$ sudo add-apt-repository ppa:webupd8team/y-ppa-manager
$ sudo apt-get update
$ sudo apt-get install y-ppa-manager 

Once you’ve installed the software, fire it up, either from the terminal or from your dash. Once you do that, select the “advanced options” from the menu and in the following menu(as shown in the screenshots), select “Try to import all missing GPG keys”.

 

Select the advanced options from the menu.
Select the advanced options from the menu.

 

Select this option to import the missing keys
Select this option to import the missing keys

 

 

 

 

 

 

 

 

 

 

After a few minutes(possibly more, this takes some time 😀 ), assuming all goes well, you’d have gotten rid of the warning that you’d been getting all this while.

 

Reference
—————–

[1] http://askubuntu.com/questions/13065/how-do-i-fix-the-gpg-error-no-pubkey

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s